View and edit data in the Grid View mode

Data Viewer lets you view and edit data directly in the grid, just like in an Excel spreadsheet.

Retrieve data for viewing

  • Execute a query that returns data.
  • Alternatively, right-click the required table to open the shortcut menu and select Retrieve Data.

Viewing data

Results output patterns

There are two patterns for the results output: the Paginal mode and Infinite scrolling.

The Paginal mode splits data into pages and is used to display data with a large number of records.

Note

By default, the Paginal mode displays 1000 records per page. You can set the Paginal mode by default and specify any preferred number of records to be displayed per page on the Tools menu > Options > Data Editor > General.

If you disable the Paginal mode, the Infinite scrolling pattern will be activated, which loads data continuously as the user scrolls down the page and allows retrieving all data at once.

Note

If you want to retrieve all data from a table with a large number of records, you will get a message warning you about the possibility of the Out of memory exception. You can choose to continue retrieving data, cancel retrieving data, or turn on the Paginal mode.

Manipulate the results output

You can use a rich set of data management options from the shortcut menu.

Viewing data - shortcut menu

To change the column order and width, as well as group them by order, drag column headers to the required place. Additionally, you can fit the column width to the column content by right-clicking the required header and selecting Best Fit on the shortcut menu. To adjust the widths of all columns at once, select Best Fit (all columns). Note that this operation can take some time if there are many records in the grid.

You can set the background and foreground colors for the grid rows. This can be done separately for odd and even rows, focused rows, selected rows, focused cells, or group rows.

Data rows can be viewed, edited and printed as cards. To learn more, refer to Viewing and editing data in the Card View mode.

To simplify the subsequent data analysis, you can use the following features:

Refresh data

To refresh data, select Refresh on the Data menu (for the data view), on the shortcut menu, or on the toolbar. To abort an overly long refresh operation, select Stop Refresh on the Data menu (for the data view) or on the toolbar.

In case the query text has been edited, and changes have been applied, to get updated data, you need to run the Execute command anew instead of refreshing the gird.

View and edit data in Data Viewer

You can view and edit data in the built-in Data Viewer. To do that, double-click the required cell in the grid or right-click it and select Data Viewer on the shortcut menu. Alternatively, use the CTRL+W, R key combination.

Data Viewer

The Data Viewer toolbar has the following buttons:

Data Viewer toolbar

Save Data The Save Data button allows saving data to a file.

Copy, Paste, Cut These buttons let you Copy, Paste, and Cut data, respectively.

The following buttons allow viewing data in multiple formats:

Hexadecimal View Hexadecimal View

Text View Text View

XML View XML View

HTML View HTML View

Web View Web View

Rich Text View Rich Text View

PDF View PDF View

JSON View JSON View

Image View Image View

View White Spaces This button, when enabled, makes white spaces visible.

Word Wrap This button enables Word Wrap in the Data Viewer window.

Select data

In order to copy or edit data, you need to select it.

Data can be selected just like cells in a spreadsheet. To select data, do one of the following actions:

  • Move the mouse pointer across the grid holding the left mouse button.

  • Click the first cell of the required data range, press and hold SHIFT, and then select the last cell. A rectangular range of cells will be selected.

  • Use CTRL+A to select all cells in the grid.

Using the CTRL key, you can include/exclude cells from selection. Any number of rows may be copied and pasted to another application (for example, a spreadsheet). However, when you paste data in the data grid, only the first row will be pasted.

Edit data in Data Editor

When Query Builder executes a statement returning a result set, the retrieved data is displayed in the same SQL document in Data Editor. Its toolbar has the following buttons:

Data Editor toolbar

Refresh data These buttons let you refresh and stop refreshing data in the grid, respectively.

Cached Updates Mode The Cached Updates Mode lets you control data editing within a single database object. If you enable this mode for an object, your changes will be stored locally on the client side until you click Apply Changes. If you do not need the changes to be applied, click Cancel Changes. If you close a document in the Cached Updates Mode, you will cancel all the changes made since the latest Apply Changes command.

Paginal Mode The Paginal Mode button allows switching to the Paginal mode.

Switching between pages These buttons allow to Go to First Page, Go to Previous Page, select the number of records per page, Go to Next Page, and Go to Last Page, respectively.

Grid and Card View modes These buttons allow switching between Grid View and Card View.

Show Group by Box The Show Group by Box button allows grouping data by column.

Auto-search mode This button enables the auto-search mode.

Data export This button enables data export.

Switching from read-only This dropdown menu allows switching from the read-only mode to editing.

Note

Computed columns always remain in the read-only mode and cannot be edited.

The bottom of the grid has the following buttons:

Data Editor toolbar

Records These buttons let you navigate down the grid one record at a time, or instantly get to the first or the last record in the grid.

Append and delete These buttons let you append or delete records from the grid.

Apply or cancel changes These buttons let you apply or cancel changes made during editing.

Note

If you are editing data in a table with a foreign key, you can view the data of the related table using the foreign key lookup feature right in Data Editor.

The data of the related table is shown after you click the button next to the field you want to edit. The corresponding record in the related table will be highlighted, as shown in the screenshot below.

Foreign key lookup

Copy and paste data

You can copy selected data by selecting Copy or Copy With Headers on the shortcut menu.

Alternatively, you can copy selected data using shortcuts:

  • Use CTRL+C to copy data.

  • Use CTRL+SHIFT+C to copy data with headers.

Additionally, you can select Copy Data As on the shortcut menu to Copy Column Names Only or Copy Column Names and Types.

Similarly, you can paste data by selecting Paste or Paste As New Records on the shortcut menu or using the CTRL+V shortcut.

Insert and delete data

For these operations, you can use the shortcut menu or the corresponding buttons under the grid. For example, you can do the following:

  • To insert NULL (instead of an empty string), select Set Value To > Null on the shortcut menu. You can also use the CTRL+0 key combination.

Note

Use the Set Value To menu to quickly set an empty string, zero, or the current date.

  • To add a new record, select the Append option on the shortcut menu or click the + button under the grid.

  • To delete a record from the grid, select the Delete option on the shortcut menu or click the - button under the grid. You can also use the CTRL+DEL key combination.

Note

Some queries return read-only data; for example, queries with aggregate functions (e.g. COUNT, AVG) or data, retrieved from non-updatable views. Such data cannot be edited. It is also impossible to edit the results of multiple SELECT statements.

Row and cell indicators

When working with the grid, you can see special indicators next to the focused cell. These indicators reflect the current editing state.

Focused row The row is focused.

Editing The row is being edited.

Row edited The row has been edited.

Invalid value An invalid value has been entered into a cell. You must either enter a valid value or press the ESCAPE key to cancel changes.