View and edit data in the Card View mode

The Data Editor of Query Builder lets you view, edit, and print data in the Card View mode, where each data row (record) is represented as a card with a ‘Record N’ caption and number.

To enable the Card View mode, click the Switch to Card View button on the Data Editor toolbar. To return to the Grid View mode, click the Switch to Grid View button on the Data Editor toolbar.

Card View

You can view or edit data in the same way as in the Grid View. Data cards can be expanded and collapsed with the corresponding button in the upper right corner of the card.

As opposed to the vertical scrolling of the Grid View, the Card View features horizontal scrolling.

Results output patterns

There are two patterns for the results output: the Paginal mode and the Infinite scrolling.

The Paginal mode splits data into pages and is used to display data with a large number of records.

Note

By default, the Paginal mode displays 1000 records per page. You can set the Paginal mode by default and specify any preferred number of records to be displayed per page on the Tools menu > Options > Data Editor > General.

If you disable the Paginal mode, the Infinite scrolling pattern will be activated, which loads data continuously as the user scrolls down the page and allows retrieving all data at once.

Note

If you want to retrieve all data from a table with a large number of records, you will get a message warning you about the possibility of the Out of memory exception. You can choose to continue retrieving data, to cancel retrieving data, or to turn on the paginal mode.

Manipulate the results output

You can use a rich set of data management options from the shortcut menu.

Viewing data - shortcut menu

Note

Use the Set Value To menu to quickly set an empty string, zero, or the current date.

Refresh data

To refresh data, select Refresh on the Data menu (for the data view), from the shortcut menu, or on the toolbar. To abort an overly long refresh operation, select Stop Refresh on the Data menu (for the data view) or on the toolbar.

Sort cards

You can sort cards by column. To do that, go to the required column and use the sorting glyph to select the Ascending or Descending order.

To clear sorting on the current column, select Clear Sorting from the shortcut menu.

You can print data by right-clicking a card and selecting Print from the shortcut menu. Alternatively, press CTRL+P. The Preview window opens.

Printing - Preview window

The Preview window allows to preview and adjust cards before printing. You can view thumbnails for each page, search for required data, customize printing options, open/save printing documents in the .prnx format, conduct page setup (format, width, height, orientation, and margins), add header and footer, zoom in and out, and quickly navigate across pages.

Print options can be configured on the Tools menu > Options> Data Editor > Print. Alternatively, select Options from the shortcut menu.

View and edit data in Data Viewer

You can view and edit data in the built-in Data Viewer. To do that, double-click the required cell on the card or right-click it and select Data Viewer from the shortcut menu. Alternatively, use the CTRL+W, R key combination.

Data Viewer

The Data Viewer toolbar has the following buttons:

Data Viewer toolbar

Save Data The Save Data button allows saving data to a file.

Copy, Paste, Cut These buttons let you Copy, Paste, and Cut data, respectively.

The following buttons allow viewing data in multiple formats:

Hexadecimal View Hexadecimal View

Text View Text View

XML View XML View

HTML View HTML View

Web View Web View

Rich Text View Rich Text View

PDF View PDF View

JSON View JSON View

Image View Image View

View White Spaces This button, when enabled, makes white spaces visible.

Word Wrap This button enables Word Wrap in the Data Viewer window.

Select data

In order to copy or edit data, you need to select it.

To select multiple cards, do one of the following actions:

  • Move the mouse pointer across the required cards holding the left mouse button.

  • Click the first card of the required data range, press and hold SHIFT, and then select the last card.

  • Use CTRL+A to select all cards.

Using the CTRL key, you can include/exclude cards from selection.

Edit data in Data Editor

When Query Builder executes a statement returning a result set, the retrieved data is displayed in the same SQL document in Data Editor. Its toolbar has the following buttons:

Data Editor toolbar

Refresh data These buttons let you refresh and stop refreshing data, respectively.

Cached Updates Mode The Cached Updates Mode lets you control data editing within a single database object. If you enable this mode for an object, your changes will be stored locally on the client side until you click Apply Changes. If you do not need the changes to be applied, click Cancel Changes. If you close a document in the Cached Updates Mode, you will cancel all the changes made since the latest Apply Changes command.

Paginal Mode The Paginal Mode button allows switching to the paginal mode.

Switching between pages These buttons allow to Go to First Page, Go to Previous Page, select the number of records per page, Go to Next Page, and Go to Last Page, respectively.

Grid and Card View modes These buttons allow switching between Grid View and Card View.

Show Group by Box The Show Group by Box button allows grouping data by column.

Auto-search mode This button enables the auto-search mode.

Data export This button enables data export.

Switching from read-only This dropdown menu allows switching from the read-only mode to editing.

Note

Computed columns always remain in the read-only mode and cannot be edited.

Under the cards, you have the following buttons:

Data Editor toolbar

Records These buttons let you navigate down the card one record at a time, or instantly get to the first or the last record in the card.

Append and delete These buttons let you append or delete records from the card.

Apply or cancel changes These buttons let you apply or cancel changes made during editing.

Note

If you are editing data in a table with a foreign key, you can view the data of the related table using the foreign key lookup feature directly in Data Editor.

The data of the related table is shown after you click the button next to the field you want to edit. The corresponding record in the related table will be highlighted, as shown in the screenshot below.

Foreign key lookup

Copy and paste data

You can copy selected data by selecting Copy or Copy With Headers from the shortcut menu.

Alternatively, you can copy selected data using shortcuts:

  • Use CTRL+C to copy data.

  • Use CTRL+SHIFT+C to copy data with headers.

Additionally, you can select Copy Data As from the shortcut menu to Copy Column Names Only or Copy Column Names and Types.

Similarly, you can paste data by selecting Paste or Paste As New Records from the shortcut menu or using the CTRL+V shortcut.

Insert and delete data

For these operations, you can use the shortcut menu or the corresponding buttons under the cards. For example, you can do the following:

  • To insert NULL (instead of an empty string), select Set Value To > Null from the shortcut menu. You can also use the CTRL+0 key combination.

Note

Use the Set Value To menu to quickly set an empty string, zero, or the current date.

  • To add a new record, select the Append option from the shortcut menu or click the + button under the cards.

  • To delete a record from the card, select the Delete option from the shortcut menu or click the - button under the cards. You can also use the CTRL+DEL key combination.

Note

Some queries return read-only data; for example, queries with aggregate functions (e.g. COUNT, AVG) or data, retrieved from non-updatable views. Such data cannot be edited. It is also impossible to edit the results of multiple SELECT statements.

Row and cell indicators

When working with the cards, you can see special indicators next to the focused cell. These indicators reflect the current editing state.

Focused row The row is focused.

Editing The row is being edited.

Row edited The row has been edited.

Invalid value An invalid value has been entered into a cell. You must either enter a valid value or press the ESCAPE key to cancel changes.