User Interface Elements

This topic provides you with the basic information about managing your environment workspace. Environment workspace consists of toolbars, tool windows, menus and document area. To personalize menus and toolbars and to adjust their behavior to your needs, point to Toolbars in the View menu, and click Customize.

Toolbars

A toolbar is a container for a group of commands or controls that are typically related in their function.

dbForge Schema Compare for SQL Server supports dockable toolbars. A dockable toolbar can be attached, or docked, to any side of its parent window, or it can be detached, or floated, in its own mini-frame window. This article explains how to use dockable toolbars in your applications.

Note

If you drag a toolbar to the right or left side of the window, toolbar drop-down lists or combo boxes will not be available. For example, if you drag the Connection toolbar to the right or left side of the window, the Connection box will not be available.

The environment has a set of toolbars where reside buttons, using which you can accomplish most frequent tasks. The toolbar you can access depends on the kind of the document being currently active. If it is not visible, right-click on toolbars area and choose one on the shortcut menu.

You can control which toolbars are allowed to appear, and which ones must be always visible. By default, when you switch between views or documents, corresponding toolbars appear and disappear. When a toolbar is visible, right-click on toolbar area and deselect its item in the shortcut menu to prevent it from showing even if the corresponding view is active. If you want to make a toolbar always visible, select it in the shortcut menu, when the corresponding document or view is not active. To return a toolbar to its default state, select it in the shortcut menu when the corresponding document or view is active. You can edit any toolbar, delete, or add your own in the Customization dialog box. To open it, choose Customize on a toolbar shortcut menu.

Document Area

Document area typically displays SQL code or diagrams. Document area size can be manipulated by resizing docked tool windows. To free more space for documents, you can put docked tool windows to auto-hide mode by clicking the pushpin icon on the title bar of the window.

You can arrange documents in tab groups in document area. To create a tab group or move document to another tab group, simply drag a document to a drop point. Dragging a document to an arrow drop point will create a new tab group; dragging it to the tab group central drop point will move the document to this tab group.

Multiple documents can be organized into horizontal or vertical tab groups for organizing a workspace for working with several documents at the same time. A new document tab group can be created either by dragging a document to the required place or by selecting New Horizontal Tab Group or New Vertical Tab Group on the document header shortcut menu.

Documents can be moved between tab groups by dragging-n-dropping or by selecting required command from the shortcut menu. You can expand a tab group to the whole document area and restore document tab groups’ sizes by selecting Prominent from the document header shortcut menu.

Switching Between Windows

This section contains information about how to switch between documents and tool windows.

To cycle through open documents, use CTRL+TAB or CTRL+SHIFT+TAB key combinations. Press CTRL+TAB to switch to the previously used document. Pressing CTRL+TAB again will return you to current document. Hit TAB key while holding CTRL key to cycle through recent documents stack. You can also use CTRL+SHIFT+TAB combination to browse documents in another direction.

To navigate from the current document tab to the next tab, use CTRL+ALT+PGDOWN key combination. To navigate from the current document tab to the previous tab, use CTRL+ALT+PGUP key combination.

You can also switch between documents in the following ways.

  • By clicking document titles.

  • By clicking the down arrow near the right upper corner of the document area and selecting document name on the appeared menu.

  • By selecting document on the Window menu.

  • By selecting document in the Windows dialog and clicking the Activate button.

To activate a tool window, use its shortcut key.

Switching to another skin

dbForge Schema Compare for SQL Server provides you with several types of a skin. To switch to another skin, on the Tools menu, select Skin, and then click the skin name you like.

The following skins are available in dbForge Schema Compare for SQL Server:

  • Visual Studio 2013 Blue
  • Visual Studio 2013 Light
  • Visual Studio 2013 Dark
  • Visual Studio 2010
  • Metropolis
  • Metropolis Dark
  • Office 2010 Silver
  • Office 2010 Blue
  • Office 2010 Black
  • Office 2013
  • Office 2013 Dark Gray
  • Office 2013 Light Gray
  • Windows 7