User Interface Elements

This topic provides some basic information about managing your environment workspace. Environment workspace consists of toolbars, tool windows, menus, and document area. To personalize menus and toolbars and to adjust their behavior to your needs, on the View menu, point to Toolbars and click Customize.

Toolbars

A toolbar is a container for a group of commands or controls that are typically related in their function.

Documenter for Oracle supports dockable toolbars. A dockable toolbar can be attached or docked to any side of its parent window, or it can be detached, or floated in its mini-frame window. This article explains how to use dockable toolbars in your applications.

Note

If you drag a toolbar to the right or left side of the window, toolbar drop-down lists or comboboxes will not be available. For example, if you drag the Connection toolbar to the right or left side of the window, the Connection box will not be available.

The environment has a set of toolbars where reside buttons, using which you can accomplish the most frequent tasks. The toolbar you can access depends on the kind of the document being currently active. If it is not visible, right-click on toolbars area and choose one from the shortcut menu.

You can control which toolbars are allowed to appear and which must be always visible. By default, when you switch between views or documents, corresponding toolbars appear and disappear. When a toolbar is visible, right-click on toolbar area and deselect its item on the shortcut menu to prevent it from showing even if the corresponding view is active. If you want to make a toolbar always visible, select it on the shortcut menu, when the corresponding document or view is not active.

To return a toolbar to its default state, select it on the shortcut menu the when corresponding document or view is active. You can edit any toolbar, delete, or add your own in the Customization dialog box. To open it, choose Customize on a toolbar shortcut menu.

Document Area

Document area typically displays SQL code or diagrams. Document area size can be manipulated by resizing docked tool windows. To free more space for documents, put docked tool windows to auto-hide the mode by clicking the pushpin icon on the title bar of the window.

You can arrange documents in tab groups in the document area. To create a tab group or move the document to another tab group, just drag a document to a drop point. Dragging a document to an arrow drop point will create a new tab group. Dragging it to the tab group central drop point will move the document to this tab group.

Multiple documents can be organized into horizontal or vertical tab groups for organizing a workspace for working with several documents at the same time. A new document tab group can be created either by dragging the document to the required place or by selecting New Horizontal Tab Group or New Vertical Tab Group from the document header shortcut menu.

Documents can be moved between tab groups by dragging-n-dropping or by selecting the required command on the shortcut menu. You can expand a tab group to the whole document area and restore document tab groups’ sizes by selecting Prominent on the document header shortcut menu.

Switching Between Windows

This section contains information about how to switch between documents and tool windows.

To cycle through open documents, use the CTRL+TAB or CTRL+SHIFT+TAB key combinations. To switch to the previously used document, press CTRL+TAB. To return to the current document, press CTRL+TAB. To cycle through recent documents stack, press the TAB key while holding the CTRL key. You can also use the CTRL+SHIFT+TAB combination to browse documents in another direction.

To navigate from the current document tab to the next tab, use the CTRL+ALT+PGDOWN key combination. To navigate from the current document tab to the previous tab, use the CTRL+ALT+PGUP key combination.

You can also switch between documents in the following ways:

  • By clicking document titles.
  • By clicking the down arrow near the right upper corner of the document area and selecting a document name on the menu that appears.
  • By selecting a document on the Window menu.
  • By selecting a document in the Windows dialog box and clicking Activate.

To activate a tool window, use its shortcut key.

Switching to another skin

dbForge Documenter for Oracle provides several types of a skin. To switch to another skin, on the Tools menu, choose Skin and then click the skin name you like.

The following skins are available in dbForge Documenter for Oracle:

  • Visual Studio Blue
  • Visual Studio Light
  • Visual Studio Dark
  • Office 2013
  • Office 2013 Dark Gray
  • Office 2013 Light Gray
  • Bezier